summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Astals Cid <[email protected]>2018-02-21 21:29:18 +0100
committerAlbert Astals Cid <[email protected]>2018-02-21 21:31:28 +0100
commit879f40e3a86fb493493263b2213b8b0ec9d686cd (patch)
tree4bad6c1be6eada4e1ec77098524a1add9fec322e
parentce7fa7b9d8790b93eb5c955bb1f236ea8caa232d (diff)
Increase minimum required KF5 version
All the distributions tracked in repology.org that ship Qt 5.8 at least ship KF 5.33 so increase it to that version
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 609ebc6..232bd9f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,9 +9,9 @@ set (KDE_APPLICATIONS_VERSION "${KDE_APPLICATIONS_VERSION_MAJOR}.${KDE_APPLICATI
project(okular VERSION 1.3.${KDE_APPLICATIONS_VERSION_MICRO})
set(QT_REQUIRED_VERSION "5.8.0")
-set(KF5_REQUIRED_VERSION "5.16.0")
+set(KF5_REQUIRED_VERSION "5.33.0")
-find_package(ECM 5.19.0 CONFIG REQUIRED)
+find_package(ECM 5.33.0 CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
include(ECMInstallIcons)