summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Gräßlin <mgraesslin@kde.org>2017-02-17 06:09:29 (GMT)
committerMartin Gräßlin <mgraesslin@kde.org>2017-02-17 06:12:57 (GMT)
commitcb481b492271860586c69298395e2ba118239406 (patch)
tree9337a435b74c250c0c1ce3d7409a1ed8ff25da79
parent70d2fb2378d636ef6d052da08417b27c99182fb0 (diff)
Find minimum required Breeze version instead of current version
Summary: So far KWin put a version requirement on Breeze which is the current version number of KWin. This is technically correct, but distributions seem to have problems with it. E.g. I noticed twice in Debian testing that kwin defaults to Plastik which happens when Breeze is not found. I reported it, it got fixed, now it's again broken. Thus I think that distributions have problems with the requirement of building Breeze prior to KWin. As KWin does not depend on the minor version, let's depend only on the actual required version, which is 5.8 in the 5.8 branch, 5.9 in the 5.9 branch and master. Reviewers: #kwin, #plasma Subscribers: plasma-devel, kwin Tags: #kwin Differential Revision: https://phabricator.kde.org/D4644
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab636cd..a683812 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,7 +120,7 @@ set_package_properties(KScreenLocker PROPERTIES
TYPE REQUIRED
PURPOSE "For screenlocker integration in kwin_wayland")
-find_package(Breeze ${PROJECT_VERSION} CONFIG)
+find_package(Breeze 5.8.0 CONFIG)
set_package_properties(Breeze PROPERTIES
TYPE OPTIONAL
PURPOSE "For setting the default window decoration plugin")