aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikita Sirgienko <[email protected]>2018-03-18 23:48:18 +0100
committerAlbert Astals Cid <[email protected]>2018-03-18 23:49:26 +0100
commitff865d9663c45c816d0b9cb028498eda5765fbd5 (patch)
tree8583c25d907b9fe4440058a8c22b98455b122057
parent46acb9e84775ed01fbe70e807cf10a1a2bc2a375 (diff)
Specify Qt version in CMakeLists.txt
Summary: In `CMakeLists.txt` Qt version don't set, so when I have tried to build `Cantor` with my `Qt 5.5`, I have had compilation errors. So I suggest to set minimal Qt version (`5.6.0`, I have compiled with this version without errors). Reviewers: #cantor, aacid Reviewed By: aacid Subscribers: #cantor, #kde_edu Tags: #kde_edu, #cantor Differential Revision: https://phabricator.kde.org/D11465
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fdaec3..f154733 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ set(KF5_MIN_VERSION "5.15.0")
find_package(ECM 5.15.0 REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${cantor_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
-find_package(Qt5 CONFIG REQUIRED
+find_package(Qt5 5.6.0 CONFIG REQUIRED
Core
Widgets
PrintSupport